Kobo.com Purchase is Failing
Incident Report for Rakuten Kobo System
Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 12:34 EDT
Monitoring
We are currently monitoring the situation.
Posted Sep 10, 2024 - 12:22 EDT
Investigating
We are currently investigating this issue.
Posted Sep 10, 2024 - 12:05 EDT
This incident affected: Apps & Ereaders (Purchase).