Performance degradation in Kobo purchases
Incident Report for Rakuten Kobo System
Resolved
The issue was resolved from 12:18 PM EST
Posted Jan 10, 2025 - 13:04 EST
Monitoring
The situation has improved and its being improved
Posted Jan 10, 2025 - 12:38 EST
Investigating
Kobo Teams is investigating the issue.
Posted Jan 10, 2025 - 09:53 EST
This incident affected: Kobo.com (Purchase).