Maintenance Outage
Incident Report for Rakuten Kobo System
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 15:22 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2023 - 13:32 EDT
Investigating
We are currently investigating this issue.
Posted Sep 07, 2023 - 13:17 EDT
This incident affected: Kobo.com (Sign Up / Sign In, Browse, Purchase, User Libraries) and Kobo Writing Life.