Android Purchasing is down

Incident Report for Rakuten Kobo System

Resolved

The issue was resolved at 11:09 AM EST
Posted Mar 15, 2025 - 11:21 EDT

Investigating

Kobo team is investigating the issue.
Posted Mar 15, 2025 - 10:57 EDT
This incident affected: Kobo.com (Purchase).