September 10- Broken Images on web site
Incident Report for Rakuten Kobo System
Resolved
The issue has been resolved and customers can now browse and purchase on Kobo.com without issue. Thank you for your patience.
Posted Sep 10, 2023 - 23:20 EDT
Update
We are continuing to investigate this issue.
Posted Sep 10, 2023 - 22:22 EDT
Update
We are continuing to investigate this issue.
Posted Sep 10, 2023 - 21:41 EDT
Investigating
We are currently investigating this issue.
Posted Sep 10, 2023 - 21:41 EDT
This incident affected: Kobo.com (Sign Up / Sign In, Browse, Purchase, User Libraries) and Apps & Ereaders (Purchase, User Libraries, Content Downloads).