Kobo.com is intermittently unavailable
Incident Report for Rakuten Kobo System
Resolved
All the services are up and running fully
Posted Mar 19, 2024 - 20:14 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 19, 2024 - 18:00 EDT
Investigating
Kobo team is currently investigating this issue.
Posted Mar 19, 2024 - 16:36 EDT
This incident affected: Kobo.com (Sign Up / Sign In, Browse, Purchase, User Libraries) and Kobo Writing Life, Content Processing, Retail Partners, tolino.