Kobo UI page is intermittently going down

Incident Report for Rakuten Kobo System

Resolved

Kobo USA homepage was rolled back to restore stability from Kobo UI to OneStore. Errors stopped post that.
Posted Jun 05, 2025 - 17:22 EDT

Investigating

Kobo teams are currently investigating this issue.
Posted Jun 05, 2025 - 16:39 EDT
This incident affected: Kobo.com (Sign Up / Sign In, Browse, Purchase, User Libraries, Kobo WishList, Kobo Blog, Item Details page, Kobo Search).