Book Stats
Incident Report for Rakuten Kobo System
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 10:09 EDT
Investigating
We’re currently experiencing an outage with the books stats on our site. The team is working to identify the issue and restore the service as soon as possible. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 12, 2023 - 19:45 EDT
This incident affected: Kobo.com (Browse).