Intermittent Failures on Ebooks/AudioBooks download
Incident Report for Rakuten Kobo System
Resolved
This incident has been resolved.
Posted Mar 23, 2024 - 14:58 EDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2024 - 14:01 EDT
This incident affected: Apps & Ereaders (Content Downloads).