Site outage
Incident Report for Rakuten Kobo System
Resolved
This incident has been resolved.
Posted Aug 20, 2023 - 10:26 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 20, 2023 - 10:21 EDT
Investigating
We are currently investigating this issue.
Posted Aug 20, 2023 - 10:01 EDT
This incident affected: Kobo.com (Sign Up / Sign In, Browse, Purchase, User Libraries).