Kobo.com search page is down
Incident Report for Rakuten Kobo System
Resolved
Kobo.com search is recovered. The services are up and running now.
Posted May 02, 2024 - 10:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 10:43 EDT
Investigating
Kobo.com search page is down. The team is currently working on troubleshooting the issue
Posted May 02, 2024 - 10:16 EDT
This incident affected: Kobo Search.