Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2025 - 13:00 EDT
Scheduled
Kobo Team will be Migrating Purchasing databases. while kobo.com will be available for browse and search the purchasing will be down approximately 30 minutes.
Posted Mar 09, 2025 - 11:40 EDT
This scheduled maintenance affected: Kobo.com (Purchase).